Back to overview
Resolved

Panel Degradation

Jun 26, 2026 at 10:03am UTC
Affected services
Hosting Panel

Resolved
Jun 29, 2026 at 1:59am UTC

Issue has been resolved. Thank you for your patience!

Updated
Jun 28, 2026 at 7:51pm UTC

We implemented a fix and are currently monitoring the result.

Created
Jun 26, 2026 at 10:03am UTC

We are investigating connection issues affecting panel accessibility due to upstream network instability. Hosted servers are unaffected. A brief interruption to active panel sessions may occur around 5:55 PM due to emergency maintenance by our provider.